Tivo.com website not working? Is it down right now?

Tivo.com Server Status Check
tivo.com screenshot
TiVoWebsite Name:
www.tivo.comURL Checked:
Response Time:
Last Down:
Checking TiVo
Please wait while we check the server...
TiVo Website Status History
Tivo.com server report and response time

The above graph displays service status activity for Tivo.com over the last 10 automatic checks. The blue bar displays the response time, which is better when smaller. If no bar is displayed for a specific time it means that the service was down and the site was offline.

Service Status History

DateTimePing Time DateTimePing Time
25.May.2016
11:41236.26 ms. 
25.May.2016
13:50240.44 ms.
25.May.2016
17:00234.21 ms. 
25.May.2016
20:07237.26 ms.
25.May.2016
22:10236.06 ms. 
26.May.2016
00:32235.47 ms.
26.May.2016
02:39236.89 ms. 
26.May.2016
05:11236.09 ms.
26.May.2016
09:33235.84 ms. 
26.May.2016
13:36235.63 ms. 

* Times displayed are PT, Pacific Time (UTC/GMT 0)  |  Current server time is 14:31

We have tried pinging TiVo website using our server and the website returned the above results. If tivo.com is down for us too there is nothing you can do except waiting. Probably the server is overloaded, down or unreachable because of a network problem, outage or a website maintenance is in progress...

Can't Access TiVo - Troubleshooting Instructions

If the site is UP but you cant access the page, try one of the below solutions:

Browser Related Problems

Force a full refresh for the site. This can be achieved by pressing CTRL + F5 keys at the same time on your favourite browser (Firefox, Chrome, Explorer, etc.)

Clear the temporary cache and cookies on your browser to make sure that you have the most recent version of the web page. For instructions choose your browser :

Fix DNS Problems

A Domain Name System (DNS) allows a site IP address (192.168.x.x) to be identified with words (*.com) in order to be remembered more easily, like a phonebook for websites. This service is usually provided by your ISP.

Clear your local DNS cache to make sure that you grab the most recent cache that your ISP has. For Windows - (Start > Command Prompt > type "ipconfig /flushdns" and hit enter). For details choose your operating system :

If you can access a website at office or from a 3G network yet it's not working on your computer, it is a good idea to use an alternative DNS service other than your ISPs. OpenDNS or Google Public DNS are both excellent and free public DNS services.

Check our help page for step-by-step instructions on how to change your DNS.

Having Problems with Accessing Tivo.com?
▼ LAST 7 DAYS ...
Ashley Cobb · 2 days 12 hours ago
· · Chrome 50.0 on Android

My Tivo is down getting error 133 anybody else having this problem?

Sandy Hobbs · 21 May 2016 - 02:51
· · Firefox 46.0 on Mac

My Tivo is down getting error 133 anybody else having this problem?

▼ LAST 30 DAYS ...
Jan Gleason · 17 May 2016 - 23:11
· · Safari 600.1.4 on iPad

Error code 133----this is getting old fast! When are you going to fix this tivo?...

Judy Thomas · 10 May 2016 - 03:58
· · Chrome 50.0 on Android

Error code 133 for 3 days now

▼ LAST 6 MONTHS ...
Karen Loader · 21 April 2016 - 22:46
· · Android Browser 4.0 on Android

Tivo has been down since 10 am

Wendy Darcel · 21 April 2016 - 11:32
· · Chrome 49.0 on Android

Hey, our Tivo is down its been bad for 2 days now I can't get anything and none of my recorded shows. It's now 6:31am (CST)

Shannon Johnston · 31 March 2016 - 13:09
· · Chrome 49.0 on Windows

here is a temporary problem with the connection to the Tivo service (C133)".since yesturday til today. when will be fix ?

Ellen Fisher Selmasska · 30 March 2016 - 00:49
· · Chrome 49.0 on Mac

We can't delete shows. The message says "there is a temporary problem with the connection to the Tivo service (C133)".

Moira Moore · 28 March 2016 - 02:11
· · Chrome 49.0 on Windows

Tivo is down. I can't get access to netflix or youtube and the mini version in the other room doesn't work at all.

Deborah Laza Morgan · 23 March 2016 - 23:00
· · Chrome 46.0 on Windows

C133 and V52 error messages Cannot watch Live TV either but recorded shows works.

Debi Wilson · 16 March 2016 - 07:44
· · Chrome 49.0 on Windows

down here

Wandee Rivera · 10 March 2016 - 09:00
· · Chrome 34.0 on Android

My data is not working but everything else why it's still saying to wait

Delma Coulombe · 10 March 2016 - 07:57
· · Chrome 48.0 on Android

C133 Easton pa

Pickles Ferrin · 22 February 2016 - 15:53
· · Internet Explorer 11.0 on Windows

great place to check if a system is down (in real time); a real lifesaver

Phil Feldman · 22 February 2016 - 12:59
· · Safari 9.0.3 on Mac

Manage Account is so slow as to be unusable

Jeremy Robertson · 18 February 2016 - 20:59
· · Chrome 48.0 on Windows

Tivo sux down again

Craig Hammitt III · 18 February 2016 - 18:09
· · Firefox 44.0 on Windows

Tivo.com is down right now

Lisa Joy Avelar · 13 February 2016 - 04:26
· · Safari 9.0.3 on Mac

no tivo connection... has been going on for at least an hour

Stafford Doc Williamson · 9 February 2016 - 00:32
· · Chrome 48.0 on Windows

Error C133 on menu screen for over 3 weeks now. Every report says all is working, but the error remains. Is there a fix? When if not now.

Lori Robinson · 4 February 2016 - 17:47
· · Internet Explorer 11.0 on Windows

When on a TV channel, the screen is black. When selecting a recorded show to watch, the screen is black. I navigate to Netflix and the show appears but no sound.
Everything was working fine last night.

Lisa Richter McNamara · 4 January 2016 - 05:56
· · Chrome 47.0 on Windows

Like the other recent comments...our tivo has not connected since 12/29. Tivo said that it's an experienced by California Comcast customers and that Tivo was working with Comcast to resolve the issue.

Kevin Sibley · 4 January 2016 - 05:06
· · Chrome 47.0 on Windows

I've have not been able to connect since 12/23/15, Tivo said the problem is with Comcast and Comcast was clueless. I tried using a mobile hotsptop with my mobile provider and I was able to connect. Not idea for the long term but at least I have the guide for two more weeks.

David Cagle · 4 January 2016 - 04:14
· · Chrome 47.0 on Mac

Tivo Guide servers down. No updates since 12/29 (like many others have reported). I get an error "Failed during configuration" - Contacted Tivo Support yesterday via chat and they blame it on Comcast. They better fix it by 1/9 or my Tivos are unusable.

Lauri Smith · 4 January 2016 - 03:57
· · Firefox 43.0 on Mac

Tivo down. No updates since 12/29 (like many others have reported). I get an error "Failed during configuration" on both of my devices. I have rebooted everything. Nothing fixes it.

Brian Garman · 3 January 2016 - 19:40
· · Chrome 47.0 on Windows

Same issue connecting to tivo servce since 12/29 using Consolidated Communications ISP. Tried connecting to AT&T WiFi hotspot (cellular), connection to tivo service - SUCCESSFUL.
Called Consolidated and reported this test, they are looking into it from their side now.

Michael Alexics · 3 January 2016 - 13:03
· · Chrome 47.0 on Windows

My Tivo Romeo has been failed in connecting since Dec 29th and is not connecting no matter if its wired or wifi and i restarted it 4 times!!!!

Marcus Dickinson · 2 January 2016 - 20:24
· · Chrome 47.0 on Android

It keeps saying could not get account status. Last update was 12/29.

Douglas Tao · 2 January 2016 - 14:05
· · Safari 9.0 on iPad

Getting Error N15 on all my Tivos (I have 4) "Could not get account status"
Last guide update varied from 12/19 to 12/30/2015.

Terri Bonzo · 2 January 2016 - 12:46
· · Chrome 47.0 on Android

Down. C133 error. This has been happening fairly consistently for over a week now. :(

James Carr · 19 December 2015 - 23:03
· · Firefox 42.0 on Windows

My tivo has been down since 12 -16-15 I need it fixs .Thank you . Jim Carr.

Sarah Ritter · 11 December 2015 - 20:09
· · Chrome 47.0 on Windows

Tivo down. my tivo was fine 30 mintes ago and now its not. would like to know why I am getting this c133 error for? specially when you say its up

▼ MORE THAN 6 MONTHS AGO ...
Venetia Kudrle · 12 October 2015 - 22:58
· · Safari 9.0 on Mac

My tivo conenction has been down for at least several hours. message 133 says this is a temprorary issue and will be fixed shortly and to try again in a few minutes.

Beth Hammond Gnuse · 30 August 2015 - 21:37
· · Safari 8.0 on iPad

I've been getting the c133 message for about 2 weeks. It's recording, but I can't search or connect on my iPad. Please help!

SimbiAni Buchman · 2 April 2014 - 07:29
United States · Comcast Cable

C133'ing in northeastern MA for the past few days, ugh! C'mon TiVo, I want my video providers baack.. including TiVo-exclusive Xfinity OnDemand! ;(

ALSO: note to who runs this site, FiX iT please so that THE CHECKER STOPS DROPPiNG IMPORTANT PARTS OF THE URL.. ie "mind.tivo.com" keeps on re-directing to ONLY "tivo.com" which is really not the issue! >.>

Judy Barrett · 14 December 2013 - 03:18
United States · Time Warner Cable

I've had that C133 message on my Premiere for a solid month now. My old Series II is working fine. The premiere has been down so long there is no program information, I can only record manually. Utterly outrageous. They say they've been hacked. They're working on it. They seem terribly unconcerned.

Richard Smith · 10 December 2013 - 15:48
United States · WideOpenWest

Well here we go again... the C133 error is back, and just got my newest TiVo up and running. Now all 3 are affected. Wife is NOT happy, and I can't blame her. Auburn, Alabama area

'Rik' Alan Camerik Heller · 4 December 2013 - 12:09
United States · Time Warner Cable

My TiVo experience has been horrific. And I am a network geek deluxe. The customer service has nonsensical pablum. I have 3 units, bought and paid with their monthly service fee that I will be cancelling and returning the gear asap. 3 weeks wasted.

Christopher Weaver · 4 December 2013 - 11:55
United States · Comcast Cable

Wish this page could tell if the TiVo service was up or not, this is just for their website.

William Murray · 4 December 2013 - 04:03
United States · COMBNET

I was down all yesterday (Dec 4th) afternoon and evening, had same error message this morning but restarted Tivo and Router (after forcing a connection to the Tivo Service), things seem to be ok now.

Kendall Nygren · 4 December 2013 - 02:30
United States · Comcast Cable

Service came back for a short time last night, out again this morning. C133.

Richard H. Shores · 4 December 2013 - 00:19
United States · Comcast Cable

2:16am CST ---> TiVo service is still down...C133 message. The service has been down since 2pm Monday, 12-3-2013. Highly unusual and annoying.

Marc Johnson · 3 December 2013 - 22:27
United States · Comcast Cable

TiVo been down with C133 error since using it at 4 pm. EST Woodbury, N.J. Time to get it fixed TiVo.

Richard Smith · 3 December 2013 - 22:25
United States · WideOpenWest

Now I have lost most of my channels on both my boxes. Only a few left. Anybod else lose this too?

Edit: Should have mentioned I had live channels up until now... now have lost them too.

Update: NEW error code is "problem with the signal on this channel. Trying again (V53). This is in addition to the earlier problems all report. Now box is a brick.

Jason Sobota · 3 December 2013 - 21:54
United States · Comcast Cable

Still having trouble myself, has been giving C133 for the past 5 hours.

Richard Smith · 3 December 2013 - 21:36
United States · WideOpenWest

And I am changing over from WOW cable box TOMORROW to a Premiere 4 being installed TOMORROW! What timing!!

Tom Moore · 3 December 2013 - 21:23
United States · Comcast Cable

I didn't check the web site but I noticed a problem with my Iphone when trying to interface with the Tivo about 6 pm this evening.

Michael Roper · 3 December 2013 - 20:21
United States · Comcast Business Communications

The service outage began for me immediately after TiVo pushed out some three-part video on Premiere usage (or some such, I haven't watched them). Still down hours later. In Seattle.

Shawn Kirk · 3 December 2013 - 20:17
United States · Time Warner Cable

Oviedo, Florida here.

I also have the C133 error on all my Tivo Premiere 4 and Mini's. Did the usual reboots and still have the error. However, one of my Mini's has successfully made it through the Network Connection exercise under the Settings and shows successful. But when I back out to Tivo Central... I still have the C133 error.

The thing that puzzles me is why does Netflix and Hulu Plus route through Tivo Servers anyway? If the Tivo has internet access and the Tivo Servers go down ... you should still be able to use Netflix and Hulu Plus! WTF Tivo?

Dennis Gowen · 3 December 2013 - 19:29
United States · Charter Communications

and right back down. sorry for multiple posts. i would have just deleted if i could

Dennis Gowen · 3 December 2013 - 19:24
United States · Charter Communications

getting c133 message in st. louis. can connect to tivo service fine through network settings. this has been happening a lot the last couple of days.

Edit: no sooner did i finish typing, and mine came back to life. had been down atleast 3 hours

Jorgen Christiansen · 3 December 2013 - 19:15
United States · Comcast Cable

Cranbury NJ- C133 Network down on one Roamio and 3 Tivo Mini all day. What the heck TIVO - how about a public acknowledgement...

Steve King · 3 December 2013 - 18:43
United States · Cox Communications

I've been getting the C133 error for the past three hours in Florida. I've verified that my Internet and DNS are operational. I've even rebooted my Tivo.

'Rik' Alan Camerik Heller · 3 December 2013 - 17:59
United States · Time Warner Cable

TiVo service is absurdly useless. I have never had more run arounds for a simple home network when their boxes and their cloud is flakier than a bowl of corn flakes. There I said it.

Peter Berge · 3 December 2013 - 17:50
United States · Comcast Cable

Been down for over 5 hours with a c133 error. I reset my modem and router 3x. Testing connection thru tivo works though (Weird). Pacific Northwest, WA

Richard Smith · 3 December 2013 - 16:51
United States · WideOpenWest

TiVo Down since this afternoon... no connection to system. c133. Both machines (Premier) ..Auburn, Alabama area

Scott Follmer · 3 December 2013 - 15:22
United States · Fourway Computer Products

They just informed me they do not have an ETA on when the system will be back up, but they did confirm that the service is not working, here in Etna Green Indiana.

Philip van Allen · 3 December 2013 - 15:10
United States · Los Nettos

Can't get status in Pasadena, CA either. Occasionally I can download data, but mostly not, and it can't get it's normal status.

Danielle Di Rini-Holzinger · 3 December 2013 - 14:44
United States · Comcast Cable

C133 here, too. For hours. Would have been nice if TiVo would post a service interruption on their site before I restart, check my connection, and pull all my hair out...

Scott Follmer · 3 December 2013 - 14:40
United States · Fourway Computer Products

Have repeatedly followed the steps to connect and am unable to connect to the tivo service error c133.

Fred Archibald · 3 December 2013 - 14:25
United States · Comcast Cable

Tivo service seems to be down. I was told that by a support agent while trying to trouble shoot why my Tivo would not connect. They have no idea how long until it will be back up.

David Meckes · 19 October 2013 - 07:48
United States · RCN

C133 error on my TiVo, and cant access tivo.com even though isitdownrightnow.com and other similar type services say its up.

Don Nicastro · 25 July 2013 - 00:55
United States · Fuse Internet Access

I can't even get any kind on on screen menu. The unit is on, but no picture. Been that way for 2 hours. I've tried unplugging unit. I don't know what to do.

Zack Stottlemyer · 14 June 2013 - 19:24
United States · Time Warner Cable

good I reset my router about 10 times.. I thought I was going crazy same here in florida also

Kathy Dempsey · 14 June 2013 - 15:20
United States · Astound Broadband

it's 3:15 pm, pdt and my TiVo says: Problem with the Service (C133): There is a temp prob with the TiVo Service... Please try again in a few minutes.

Submit a comment using your Facebook ID.

Is Tivo.com down for you right now? Submit your comments about Tivo.com service status or report an issue below to let others know that they aren't the only ones having trouble. Please note that your country, service provider and browser information will be displayed next to your comment to better analyze a possible outage.