Swtor.com website not working? Is it down right now?

Swtor.com Server Status Check
swtor.com screenshot
Star Wars: The Old RepublicWebsite Name:
www.swtor.comURL Checked:
Response Time:
Last Down:
Checking Star Wars: The Old Republic
Please wait while we check the server...
Star Wars: The Old Republic Website Status History
Swtor.com server report and response time

The above graph displays service status activity for Swtor.com over the last 10 automatic checks. The blue bar displays the response time, which is better when smaller. If no bar is displayed for a specific time it means that the service was down and the site was offline.

Service Status History

DateTimePing Time DateTimePing Time
27.Sep.2016
04:042.83 ms. 
27.Sep.2016
07:039.12 ms.
27.Sep.2016
19:350.87 ms. 
27.Sep.2016
23:074.31 ms.
28.Sep.2016
02:170.96 ms. 
28.Sep.2016
19:111.25 ms.
29.Sep.2016
02:460.93 ms. 
29.Sep.2016
07:480.95 ms.
29.Sep.2016
15:562.6 ms. 
29.Sep.2016
18:000.85 ms. 

* Times displayed are PT, Pacific Time (UTC/GMT 0)  |  Current server time is 18:41

We have tried pinging Star Wars: The Old Republic website using our server and the website returned the above results. If swtor.com is down for us too there is nothing you can do except waiting. Probably the server is overloaded, down or unreachable because of a network problem, outage or a website maintenance is in progress...

Can't Access Star Wars: The Old Republic - Troubleshooting Instructions

If the site is UP but you cant access the page, try one of the below solutions:

Browser Related Problems

Force a full refresh for the site. This can be achieved by pressing CTRL + F5 keys at the same time on your favourite browser (Firefox, Chrome, Explorer, etc.)

Clear the temporary cache and cookies on your browser to make sure that you have the most recent version of the web page. For instructions choose your browser :

Fix DNS Problems

A Domain Name System (DNS) allows a site IP address (192.168.x.x) to be identified with words (*.com) in order to be remembered more easily, like a phonebook for websites. This service is usually provided by your ISP.

Clear your local DNS cache to make sure that you grab the most recent cache that your ISP has. For Windows - (Start > Command Prompt > type "ipconfig /flushdns" and hit enter). For details choose your operating system :

If you can access a website at office or from a 3G network yet it's not working on your computer, it is a good idea to use an alternative DNS service other than your ISPs. OpenDNS or Google Public DNS are both excellent and free public DNS services.

Check our help page for step-by-step instructions on how to change your DNS.

Having Problems with Accessing Swtor.com?
▼ LAST 6 MONTHS ...
Lori Harting · 29 May 2016 - 00:55
· · Chrome 46.0 on Windows

been having server disconnect issues for about 12 hours now.... can log in and play for about 5 minutes then get booted. :(

Zach Marks · 25 May 2016 - 04:24
· · Chrome 48.0 on Windows

what is going on here i cant login to the server please fix

Eric Letchworth · 10 May 2016 - 02:29
· · Firefox 46.0 on Windows

@SWTOR acknowledges problem with player launch and login. posted 1 hour ago.

Thomas Kopaskie II · 10 May 2016 - 01:55
· · Chrome 50.0 on Windows

Website will not show Server Status "Unknown Error" everytime I try to load the page. Game cannot connect either, as gets "Unknown Error."

Jo Benavides · 10 May 2016 - 01:40
· · Chrome 50.0 on Windows

I can't even log in to the site or the launcher.

Robert Craven · 10 May 2016 - 01:29
· · Chrome 46.0 on Windows

out

Anthony Joseph Brun · 10 May 2016 - 01:20
· · Chrome 50.0 on Windows

The Server's up an running so try hitting ctrl+shift+esc an end task on all 3 Bitrader then relaunch SWTOR

David Batres · 10 May 2016 - 01:16
· · Chrome 50.0 on Windows

Can't log in to swtor

Colby Hancock · 30 April 2016 - 15:16
· · Chrome 49.0 on Windows

Can't log in to Shadowlands.

▼ MORE THAN 6 MONTHS AGO ...
Andrew Shaw · 25 February 2016 - 22:41
· · Firefox 44.0 on Windows

wont send me the one time password ????

Jay Sun Bak · 11 February 2016 - 21:01
· · Chrome 48.0 on Windows

cant log in

Kerr Puter · 6 February 2016 - 01:10
· · Internet Explorer 11.0 on Windows

2/5/16 8PM Eastern
Ebon Hawk server issues, massive lag times and getting disconnected.

Iti Fox · 27 January 2016 - 21:36
· · Chrome 47.0 on Windows

login server error
said to visit twitter nothing there

Eric Lycan · 14 December 2015 - 16:22
· · Chrome 47.0 on Windows

its an unscheduled maintenance it will probablt be up in a couple of hours ;)

Trudy Smith-Wilner · 14 December 2015 - 15:32
· · Firefox 42.0 on Windows

I show all servers offline when I try to log-in at 15:30 today.

Tyler Hertel · 17 November 2015 - 17:05
· · Chrome 46.0 on Windows

I see it down right now

Heidi Adkins · 17 November 2015 - 16:16
· · Firefox 42.0 on Windows

they say its mait. day but they say its up for us

Peter Krachenfels · 17 November 2015 - 13:46
· · Chrome 46.0 on Windows

Can't log in

Jessica Seda-Ruiz · 18 October 2015 - 16:28
· · Firefox 41.0 on Windows

I can log into but it won't load from the opening splash screen.

Michael Johnsen · 18 October 2015 - 08:16
· · Chrome 42.0 on Windows

harbinger just went down

Nadine Wake · 23 May 2014 - 12:45
United Kingdom · Virgin Media · Internet Explorer 11.0 on Windows

I try to log in and put in my password it directs me to the forums on the website but when I log there.. no update on the forum regarding it... help :( I am itching to get on line lol SWTOR btw thanks

Tomasz Gruca · 29 April 2014 - 17:48
Canada · TekSavvy Solutions

I heard something about there being a server maintenance today. It popped up yesterday before i logged on to play at the character select screen

Chris Sawtelle · 6 March 2014 - 17:41
United States · Verizon Internet Services

cannot reach the swtor.com page, again... but they will cheerfully take my money, when I can't cancel my subscription.

Perry Bailes · 17 February 2014 - 10:25
United States · Comcast Cable

same issue, cant log into my acct. or get the launcher to accept

Adam Weeks · 17 February 2014 - 04:36
United States · Comcast Cable

Hilarious to watch them lose money like this.

Marty Rodriguez · 16 February 2014 - 13:51
United States · Verizon Internet Services

Can't login on either my main browser Mozilla or on Chrome. Sigh, even after their website maintenance they still can't get this crap fixed. It's still just looping in loading...

Paul Mansveld · 15 February 2014 - 18:02
Australia · iiNet Limited

I can't login to re-subscribe either.

Michael Dunham · 15 February 2014 - 14:26
United States · AT&T U-verse

Can't log in!

Craig Allen · 15 February 2014 - 03:49
Australia · iiNet Limited

current issue is a broken website for login feature. Tech support claim will be a couple of hours everytime you call. Has been down for 5 days or more. I cannot pay my sub and am really really itching for wildstar to launch so over EA crap

Jason Pritchett · 14 February 2014 - 16:19
United States · Comcast Cable

Got a message saying, Down for maintenance

Renee Raynor · 14 February 2014 - 15:04
United States · Verizon Internet Services

Keeps saying it can connect to the server, I try to go to the site and the "login" part wont even load. Anyone know whats going on?

Kyle Druilhet · 14 February 2014 - 14:13
United States · Comcast Cable

having the same problem matthew

Matthew Joshua Smith · 14 February 2014 - 14:04
Brazil · Vivo

website not loading when i hit login, in other words it just loops been like that for a couple days and i cant get into my account and buy cc even if i wanted to cancel my sub i cant. fix it

Drew Hilliard · 13 February 2014 - 07:27
United States · Time Warner Cable

I cant log in on the site or use the buy feature.

Stephanie Marie Meyer · 11 February 2014 - 19:53
United States · Comcast Cable

I can't even log in to make an account for my daughter or log into my account just a big white page with the word Maintenance on it

Faith Campbell · 11 February 2014 - 09:04
United States · Time Warner Cable

I can navigate the website just fine but when I try to click login or download, it just hangs. It won't load anything.

Liz Wikberg · 2 January 2014 - 20:16
United States · Charter Communications

Yup... I keep getting no connection error but my internet is working fine with other games etc. I hope they fix it sooon.

Johnnatan Da Cruz · 2 January 2014 - 20:07
United States · Charter Communications

Origin down, Steam down, Star wars down, World of Tanks down (at least for me)... I can browse/surf the internet, but cannot play anything online. Funny

Nick Wong · 30 July 2013 - 17:52
United States · Verizon FiOS

The launcher aint working for me it keeps saying launcher is being updated. SWTOR was working fine for me 4 hours ago then it boozd out on me what is going on?

Brian Bugaj · 16 February 2013 - 22:19
United States · Verizon FiOS

Login Service is currently unavailable.

Richard Melker · 1 November 2012 - 01:42
Sweden · Bredbandsbolaget AB

Well game is up and site is up but I can´t pay for my sub, tried everything. Mailed them without answer, called them and they hung up on me. So I have uninstalled swtor sent a mail to them informing them of their lousy service, time to find another game...

Luc Parizeau · 31 October 2012 - 03:58
Canada · Videotron Ltee

They posted this 15 min ago on Twitter :

The Old Republic @SWTOR -- We are aware some players can’t access http://bit.ly/SuYweu and experience login issues. We are working on resolving it as soon as possible.

So i imagine at the rate they work it should be back and working in about 10 to 12 hours. Once again you can tell that they are not doing anything till the fast food of gaming (EA) gives them the go ahead...

Seth Gull · 31 October 2012 - 03:41
United States · CenturyLink

if they have gone down for good then they had better refund the money they just took out of my account 3 hours ago.

David Summers · 31 October 2012 - 03:36
Australia · TPG Internet Pty.

can get images working by adding cdn-www.swtor.com to your hosts file as well - I reckon that the issue is a BW name server has gone offline and they have a really short TTL on their SWTOR name. Launcher does not work as it needs access to the site to pull down the update.manifest (INFO Download: http://manifest.swtor.com/patch/retailclient_swtor.patchmanifest)

Anders Lidén · 31 October 2012 - 03:22
Sweden · Bredband2 AB

There is a thread on the forum talking about this (like I mentioned) and if you hack around with my workarounds you can go to this URL:

http://www.swtor.com/community/showthread.php?t=549859

to see the thread. BW seems to be on it but their approach is much more "it's on your side" but they havent commented in a while so it might be that they actually have started to understand that it's on their side :D

Anders Lidén · 31 October 2012 - 03:18
Sweden · Bredband2 AB

My workaround is setting my DNS servers to servers that should give me the right answers or by editing the hosts file.

Technical mumbo jumbo:

1 - It seems that most of the actual site is located on ip number 72.246.47.8 so I added swtor.com and www.swtor.com pointing to that ip number in the hosts file.

Now swtor.com loads up but without CSS.

2 - after surfing the horrible swtor.com above I found a "dns broken" forum post who suggest that you set your dns servers to either 208.67.222.222 and/or 8.8.4.4 should get you to be able to log into the game, but you'll get an empty server list so it dosn't work 100% even though.

Of course, don't forget ipconfig /flushdns after each change.

(Since you might break your computer fiddling with the above I actually won't tell you exactly HOW you do the above. Either you know what I'm talking about or you should stay away from this fiddling.)

Ava Tar · 31 October 2012 - 03:05
Australia · iiNet Limited

Yep, i was assuming sandy played a part. Appreciate the informative post Anders.

David Summers · 31 October 2012 - 03:03
Australia · TPG Internet Pty.

I figured it was DNS. Added 159.153.92.50 manifest.swtor.com www.swtor.com to my hosts file. but no joy

David Summers · 31 October 2012 - 03:02
Australia · TPG Internet Pty.

What work arounds did you use bud

Anders Lidén · 31 October 2012 - 02:59
Sweden · Bredband2 AB

After endlessly playing around with DNS settings I can tell you the following:

1 - The site is not down. It's up but not reachable due to DNS problems. If you use workarounds you can actually use the site but I have not managed to get it to load up it's CSS which means it looks like crap.

2 - The launcher is not down. It's up but unreachable due to DNS problems. If you use workarounds you can actually log into the game but the list of servers is completely empty.

This makes me belive that everything is up and working perfectly on their end. If you were online at the moment (having logged on long ago) you would still be unaffected, but as soon as you log out you cannot com back in. Worst case scenario is that the DNS servers inside EA/BW/SWToR development is feeding them correct info and they cannot even recreate the error from inside their own network.

Using my workarounds gives you tastes and crums, but nothing really useful. I do think, however, that if you manage to get the DNS server settings just right you will be able to surf the site and play the game without problem.

NOW - what could have caused this? My (very very unscientific) guess is that some DNS servers or data centers in the US are affected by the storm over there (power outage or worse) and thus we have this problem - however even if the above is right, I don't get why ALL DNS servers suddenly forgot swtor.com at the same time.

James Collar · 31 October 2012 - 02:57
United States · AT&T Internet Services

Yeah, seems to be a DNS issue. :(

Richard Melker · 31 October 2012 - 02:44
Sweden · Bredbandsbolaget AB

Well this sucks monkey scrotum, I thought I would lvl some today but no... Time to check back to requiem I guess...

John Sheff · 31 October 2012 - 02:38
United States · Verizon FiOS

worst they will not give out any info they are answering phones then just putting u on hold for hours without any info... literally name account email address and what seems to be your issue... put in issue here ie servers and site down... ask same question over and over then say ok im gonna transfer u to another dept to handle this and on hold... u would think that this issue would be right up tech supports alley

Andy Dieterle · 31 October 2012 - 02:35
United States · Time Warner Cable

wow such major bullshit, customer service has no eta, but its definitely a problem on their end.. SHOCKER

Richard Melker · 31 October 2012 - 02:31
Sweden · Bredbandsbolaget AB

Well if disney shuts it down they loose a lot of money so I think that is not an issue, but one never know. Too bad

Max Stuk · 31 October 2012 - 02:23
Switzerland · Bluewin

just that Lucas sold StarWars for disney... everythings is no longer a LucasArt property... it goes to Disney shit and make the change... I don't believe that Disney are going on a MMO thing

Richard Melker · 31 October 2012 - 02:21
Sweden · Bredbandsbolaget AB

Find no information at all, it´s like it just packed up and left

Ava Tar · 31 October 2012 - 02:20
Australia · iiNet Limited

same. is it an isp issue? I'm with Westnet

Anders Lidén · 31 October 2012 - 02:20
Sweden · Bredband2 AB

Seems to be a DNS issue. So you *can* reach it if you use the ip-number directly (though only to check if it's up or not) but you cannot log in or actually use the site.

Luc Parizeau · 31 October 2012 - 02:17
Canada · Videotron Ltee

The website or launcher are dead to me too...

Richard Melker · 31 October 2012 - 02:16
Sweden · Bredbandsbolaget AB

Can not reach the site och launcher

Submit a comment using your Facebook ID.

Is Swtor.com down for you right now? Submit your comments about Swtor.com service status or report an issue below to let others know that they aren't the only ones having trouble. Please note that your country, service provider and browser information will be displayed next to your comment to better analyze a possible outage.