Forgeofempires.com website not working? Is it down right now?

Forgeofempires.com Server Status Check
forgeofempires.com screenshot
Forge of EmpiresWebsite Name:
forgeofempires.comURL Checked:
Response Time:
Last Down:
Checking Forge of Empires
Please wait while we check the server...
Forge of Empires Website Status History
Forgeofempires.com server report and response time

The above graph displays service status activity for Forgeofempires.com over the last 10 automatic checks. The blue bar displays the response time, which is better when smaller. If no bar is displayed for a specific time it means that the service was down and the site was offline.

Service Status History

DateTimePing Time DateTimePing Time
07.Dec.2016
05:49107.91 ms. 
07.Dec.2016
08:27103.96 ms.
07.Dec.2016
11:01101.55 ms. 
07.Dec.2016
14:06103.71 ms.
07.Dec.2016
17:05110.46 ms. 
07.Dec.2016
19:2999.8 ms.
07.Dec.2016
21:31100.94 ms. 
08.Dec.2016
00:05101.18 ms.
08.Dec.2016
07:05108.39 ms. 
08.Dec.2016
09:44115.35 ms. 

* Times displayed are PT, Pacific Time (UTC/GMT 0)  |  Current server time is 11:57

We have tried pinging Forge of Empires website using our server and the website returned the above results. If forgeofempires.com is down for us too there is nothing you can do except waiting. Probably the server is overloaded, down or unreachable because of a network problem, outage or a website maintenance is in progress...

Can't Access Forge of Empires - Troubleshooting Instructions

If the site is UP but you cant access the page, try one of the below solutions:

Browser Related Problems

Force a full refresh for the site. This can be achieved by pressing CTRL + F5 keys at the same time on your favourite browser (Firefox, Chrome, Explorer, etc.)

Try alternative urls such as us.forgeofempires.com

Clear the temporary cache and cookies on your browser to make sure that you have the most recent version of the web page. For instructions choose your browser :

Fix DNS Problems

A Domain Name System (DNS) allows a site IP address (192.168.x.x) to be identified with words (*.com) in order to be remembered more easily, like a phonebook for websites. This service is usually provided by your ISP.

Clear your local DNS cache to make sure that you grab the most recent cache that your ISP has. For Windows - (Start > Command Prompt > type "ipconfig /flushdns" and hit enter). For details choose your operating system :

If you can access a website at office or from a 3G network yet it's not working on your computer, it is a good idea to use an alternative DNS service other than your ISPs. OpenDNS or Google Public DNS are both excellent and free public DNS services.

Check our help page for step-by-step instructions on how to change your DNS.

Having Problems with Accessing Forgeofempires.com?
▼ LAST 6 MONTHS ...
Renee Irvine · 17 August 2016 - 22:38
· · Chrome 51.0 on Windows

Can't log in? And wouldn't you know it!! I just purchased $80 worth of diamonds!! and tickets!! I guess I"ll have to dispute the charge if I can't play the game!!

Ariel Razali · 11 August 2016 - 20:31
· · Chrome 47.0 on Windows

can't load

Allan Ullman · 7 August 2016 - 19:19
· · Chrome 51.0 on Windows

Server appears inadequate for the customers using it, same as last year the screen overloads and goes black.

Thomas Skip Haynes · 31 July 2016 - 10:43
· · Chrome 51.0 on Windows

When I go to log in I get as far as the loading bar. But every time it stops at eith 53% or 71%. Every time. For about a week and a half now.

Allan Sal Hill · 20 July 2016 - 09:22
· · Chrome 51.0 on Windows

site not available for 2 hours now

Brian Von · 8 July 2016 - 23:26
· · Firefox 47.0 on Windows

After login, screen goes black

Onno Smit · 28 June 2016 - 11:41
· · Chrome 51.0 on Windows

no log in screen appearing and when launching, starts game over the beginning

Nutter Wheeler · 27 June 2016 - 17:25
· · Chrome 51.0 on Windows

no log in screen appearing and when launching, starts game over the beginning

David Rider · 16 June 2016 - 02:52
· · Chrome 51.0 on Windows

I'm still down...been down since this morning. won't load past68%....please help

David Rider · 15 June 2016 - 17:36
· · Chrome 51.0 on Windows

yeah my game will not load get to around 68% on the load bar. after login.and world select

Mary Ellen Mathews · 12 June 2016 - 22:29
· · Firefox 47.0 on Windows

gets to 86% and never finishes loading.

▼ MORE THAN 6 MONTHS AGO ...
Kathleen McCormack · 6 June 2016 - 16:56
· · Firefox 46.0 on Windows

Recently the treasure hunt keeps locking me up and causing a flash player crash. yesterday I could have 6 cities open at once playing, now, unless I want to crash, I can only have one city open Not going to work for me in the long term.

Debra Anderson · 3 June 2016 - 01:03
· · Silk 50.2.1 on Kindle Fire

Since you went to version 1.76.3 FOE runs slowly, then after around 3 - 5 minutes gives me an error message saying I have lost the network connection. Then my tablet tells me the CPU is too hot and needs to cool down, and that FOE could be causing it to overheat. It's getting worse each day and now I can't even send a message to my guild without getting the connectivity error and getting booted out of the game. I haven't had this problem before version 1.76.3 and never had overheating problems before; I'm running this on a Kindle Fire HDX using a 4.5.5.1 operating system running a Silk browser. The same problem happens in all 3 worlds I play on: Korch, Dunarsund and Cirguard. Anyone else having the same problem?

Peter Lustig · 30 May 2016 - 06:26
· · Chrome 50.0 on Windows

seriously buggered or down since a few hours.

Mathieu Tasserit · 23 May 2016 - 13:26
· · Firefox 46.0 on Android

Server down

Cassandra Christian · 14 May 2016 - 11:43
· · Firefox 45.0 on Windows

Is us.forgeofempires down? I have not been able to get to it from my android or my pc no matter what browser I am using.

Stephanie Wendt Sobotka · 10 May 2016 - 01:05
· · Safari 9.0 on iPhone

Grrrr what is going on. Did an update and not working anymore.

Jordan Harrell · 10 May 2016 - 00:50
· · Chrome 50.0 on Windows

I concur, I have not been able to access via Android app or GoogleChrome since roughly 11:00 am CST

Alex Guyse · 10 May 2016 - 00:50
· · Safari 9.0 on iPad

Down for me too

Jenny Butler · 10 May 2016 - 00:31
· · Firefox 46.0 on Windows

Had an update early this morning, after I got home from work 2.5 hours ago have not been able to access any server, US or otherwise.

Matt Callaway · 10 May 2016 - 00:26
· · Chrome 50.0 on Chrome OS

DNS address could not be found. It's been down half the day.

Sara Kelly Sue Shay · 10 May 2016 - 00:07
· · Chrome 50.0 on Chrome OS

DNS server cannont be found on foe.tv, forgeofempires.com and the us access page. Cant understand why it says its ok here

Tanya M Walton · 10 May 2016 - 00:05
· · Chrome 50.0 on Windows

DNS server cannont be found on foe.tv, forgeofempires.com and the us access page. Cant understand why it says its ok here

Kathie Childers · 10 May 2016 - 00:00
· · Chrome 50.0 on Windows

Telling me that the server cannot be found

Evelio Rodriguez · 6 May 2016 - 22:07
· · Chrome 50.0 on Android

Connection failed. Please check your internet connection.

My internet on my android works just fine. I can't login

Sean OBrien · 18 April 2016 - 01:24
· · Safari 9.0 on iPhone

I'm good now

Sean OBrien · 18 April 2016 - 01:21
· · Safari 9.0 on iPhone

It just says server unavailable but I am able to get on the Internet and play other apps

Thomas Burns · 18 April 2016 - 00:45
· · Chrome 49.0 on Windows

getting a white page when trying to load the game

Yuval Shalom · 13 February 2016 - 06:45
· · Chrome 48.0 on Windows

foe not working on pc at the moment

Tracy Mansueto Spesak · 3 February 2016 - 18:58
· · Chrome 47.0 on Android

Mine says I need to update but device is incompatible. It's a galaxy s6

Bobbie Buda · 2 February 2016 - 14:53
· · Chrome 47.0 on Android

It's says I have to update and I go to update at play store and then it say my devise is not conbatable know how come wazent never like that before I'm in gulid they need me everyday I spend over 500$ esay can you plz fix my gulid needs me I tried to reboot everything I don't know plzzzzz help ty

Bobbie Buda · 2 February 2016 - 13:57
· · Chrome 47.0 on Android

Been playing for mounths I'm in gulid I got jobs in gulid spenp a lot of $ on game love game I'm on andord and today it say its not conbatable y? B cuz of update not good my gulid mates need me plzzzzz fix ty

Bobbie Buda · 2 February 2016 - 12:01
· · Chrome 47.0 on Android

Feb 2 new update know I can't play been playing for mounths and spend a lot of $ plzz fix I play on andord love this game I'm in gulid and have several jobs in gulid and know I can't play my team mates are going to wondering wear I am plzzzzz fix ty and have great day.

Danny Pinnell · 27 January 2016 - 23:02
· · Chrome 47.0 on Chrome OS

Everyday its a challange . When I first started it was a breeze. Now its a fight. SO SLOWWWWWWWW

Octavio Vera · 26 January 2016 - 22:40
· · Firefox 43.0 on Windows

no carga el juego, no inicia desde ayer 25 de enero 2016,

Nick Doan · 10 January 2016 - 14:35
· · Chrome 34.0 on Android

Everything kinda works but the symbols are all messed up and stuff is jumping from side to side

Maegan Alasse Dale · 9 December 2015 - 15:41
· · Chrome 42.0 on Windows

Not loading past 76%/

Linda Ryan · 8 December 2015 - 14:45
· · Chrome 46.0 on Windows

ERROR
Invalid return code 401 from https://www.googleapis.com/oauth2/v1/userinfo with body: { "error": { "errors": [ { "domain": "global", "reason": "authError", "message": "Invalid Credentials", "locationType": "header", "location": "Authorization" } ], "code": 401, "message": "Invalid Credentials" } } I try to og in on forge of empires, and this continually comes up ???

Linda Ryan · 8 December 2015 - 14:33
· · Chrome 46.0 on Windows

down ???? 12/08/15

Maegan Alasse Dale · 1 December 2015 - 00:55
· · Chrome 42.0 on Windows

locking up on loading screen.

Jon Alamis · 30 November 2015 - 18:39
· · Safari 9.0 on Mac

It won't load.

আমি সৌরভ না · 28 November 2015 - 04:09
· · Firefox 40.0.2 on Windows

Still not working. i even tried by changing my default browser, but still the same. idk is it only me who is having this or not?

Mary Louise Mack · 27 November 2015 - 18:00
· · Firefox 42.0 on Android

Lags out and never does anything else after just a few clicks.

আমি সৌরভ না · 27 November 2015 - 16:53
· · Chrome 46.0 on Windows

slowing down a lot.. i checked my internet connection and everything is fine. Even the other websites are also going well without FoE.. dnt know whats wrong. losing interest of playing..

Amanda Sarratore · 25 November 2015 - 09:20
· · Chrome 46.0 on Windows

I was in Greifintal and it said error and tried to refresh. Now it gives Server Errors and won't load back up.

Paul A Rum · 25 November 2015 - 05:29
· · Firefox 42.0 on Windows

I was wondering why things have been quiet there since yesterday. It was working for me in Greifintal until about a half hour ago when I went for a refresh. Now I'm getting the same thing. Loads up to 56%, then says server error. I have cleared out the cache and everything, still no luck.

Herbert M Sauro · 25 November 2015 - 04:57
· · Safari 9.0 on iPad

Stops at 56%, then server error.

Allie Rosales · 25 November 2015 - 04:11
· · Chrome 46.0 on Mac

Same for me. Stops at 56% loaded then has server error

Amanda Baker · 25 November 2015 - 04:09
· · Firefox 42.0 on Windows

Server error on launch, loads only up to 56% percent

Mac Cooney · 25 November 2015 - 03:19
· · Safari 9.0 on iPhone

Does not load past 0%

Connie Reaves · 25 November 2015 - 03:08
· · Chrome 46.0 on Windows

Gets to 56% and shows server error on three cities I have and the others load up fine.

Reinhart Lombard · 25 November 2015 - 02:39
· · Safari 9.0 on iPad

FoE login screen that's about it, does not load

Cindy Riner · 25 November 2015 - 02:27
· · Internet Explorer 11.0 on Windows

FoE page starts to load and gets to about 60% and then a server error message comes up.

Beth Fry · 24 November 2015 - 11:19
· · Firefox 42.0 on Windows

Worked for about a minute then quit working.

Orlando Galli · 21 November 2015 - 18:17
· · Chrome 46.0 on Windows

No puedo comunicarme para compara en tienda. Time out

Alan Lewis · 17 November 2015 - 22:14
· · Safari 9.0.1 on Mac

not working for over 12 hrs on varous platforms

Vasilios Kapetanidis · 5 November 2015 - 13:40
· · Firefox 41.0 on Windows

it worked for me just now

Angel Chiriboga · 5 November 2015 - 13:35
· · Chrome 46.0 on Windows

nov 5th same as sept 23. it locks up.

Natascha K H Eggen · 28 October 2015 - 14:52
· · Safari 9.0 on iPad

It's been down in Cananda for 24 hrs now.keeps saying the Internet connection is down.....not the issue and then freezes.

Bobby Thomas · 11 October 2015 - 17:15
· · Chrome 45.0 on Chrome OS

This has been for 5 hours now

Bobby Thomas · 11 October 2015 - 17:14
· · Chrome 45.0 on Chrome OS

I can only get to the front page wont even load the Tabs to login

Marq Patterson · 10 October 2015 - 23:23
· · Chrome 45.0 on Windows

hmmm can't seem to get on

Chris Mazza · 7 October 2015 - 04:06
· · Firefox 38.1.0 on Windows

down currently in Seattle Washington Area

Monty Fields · 20 September 2015 - 13:30
· · Safari 8.0 on iPhone

Server unavailable in Louisville, Ky.

John Farris · 20 September 2015 - 13:20
· · Chrome 45.0 on Android

Down in alabama

Tom Munn · 20 September 2015 - 12:39
· · Chrome 45.0 on Android

Server unavailable for me in Pennsylvania

Stacey Dropiewski · 20 September 2015 - 12:19
· · Safari 7.0 on iPad

Server unavailable for me in Michigan.

Bobbie Buda · 20 September 2015 - 11:41
· · Chrome 45.0 on Android

I live in the north west of Massachusetts and it says server not available

Bobbie Buda · 20 September 2015 - 11:38
· · Chrome 45.0 on Android

It's says server not available

Ryan Rogers · 11 September 2015 - 00:26
· · Chrome 45.0 on Android

Asking me to download a 10mb upgrade but wont allow the upgrade. Phone not full.

Nicholas Heera · 10 September 2015 - 20:25
· · Chrome 28.0 on Android

Its working good for me now

Fernando Cimini · 10 September 2015 - 20:07
· · Chrome 45.0 on Windows

bah...german products, always shit

Kurtis Haines · 10 September 2015 - 20:05
· · Chrome 45.0 on Windows

IM IN!!

James Lloyd · 10 September 2015 - 19:55
· · Chrome 45.0 on Windows

it's down for me

Steve Will · 10 September 2015 - 19:54
· · Firefox 38.0 on Windows

Same behavior for me as for George Regal -- below -- prompts to "PLAY" and then after hitting "Arvahall" nothing happens... and prompts back to "PLAY" button . The "site" is responding, but the GAME is not.

George Regal · 10 September 2015 - 19:48
· · Chrome 45.0 on Windows

It prompts to "PLAY" and then after hitting "Arvahall" nothing happens... and prompts back to "PLAY" button... some kinda infinite loop...

Nicholas Heera · 10 September 2015 - 19:36
· · Chrome 28.0 on Android

Actually I signed out to write the message to say I was back in..tried to sign back in and it said "server down" :-/

Nicholas Heera · 10 September 2015 - 19:31
· · Chrome 28.0 on Android

Im back in!

Nicholas Heera · 10 September 2015 - 19:16
· · Chrome 28.0 on Android

Same here cant log in

Gordon Pocock · 10 September 2015 - 19:15
· · Safari 8.0.8 on Mac

login to FOE ok, but not Fel Franghyr

Brian Sheard · 10 September 2015 - 19:13
· · Firefox 40.0 on Windows

cant log in

Fernando Cimini · 10 September 2015 - 19:08
· · Chrome 45.0 on Windows

can't log on

Sean O'Brien · 13 July 2014 - 06:58
United States · Verizon FiOS · Chrome 35.0 on Windows

cant log on

Ann Schuster · 25 June 2014 - 08:17
Sweden · Com Hem AB · Chrome 35.0 on Windows

cant log on game

Raven Behr · 21 June 2014 - 16:36
United States · Jefferson Co. Cable · Chrome 35.0 on Windows

8 hours now. Still can't access my game. Still no answers. I have written reports but still cannot get answers. Cannot even find a 'contact us' button anywhere on syfy.Com. This is ridiculous. I'm so pissed. Does anyone work for this website that i can talk to? Does anyone give half a shit? This is not how i wanted to spend my day off!

Jenny Butler · 18 May 2014 - 17:23
United States · Cox Communications · Firefox 29.0 on Windows

US server has been down for last 15 minutes.

Eternal Mercy · 18 May 2014 - 16:51
United States · Cox Communications · Chrome 34.0 on Windows

Not able to log onto US server. Beta server is working fine.

Sandy A McFerren · 17 May 2014 - 21:59
United States · Cox Communications · Chrome 34.0 on Windows

several friends across the world cannot get in to FOE.. but others are having no issue.. speaking on facebook about it at 11:59 pm central .. 5/17/14

Carol Dimmitt · 23 April 2014 - 20:19
United States · Suddenlink Communications

The servers were down for what ever reason..maybe bug fixes, maybe updates, maybe cause they need sleep (kidding of course) it happens, will happen again.. Love this game

Kevin Smith · 20 April 2014 - 19:02
United States · Comcast Cable

The site seems down at the moment

Calvin Chukes Jr · 17 April 2014 - 11:19
United States · Plant TiftNet

logon but can't play

Linda Ryan · 26 March 2014 - 21:17
United States · Comcast Cable

can't access log in via google + link have tried two separate browsers ?

Murat Oksüm · 1 March 2014 - 02:55
Denmark · Tele Danmark

cant access either facebook login timeout

Joe Bloggs · 1 March 2014 - 01:11
Ireland · Fastcom Broadband Limited

It is giving a connection timeout all morning

Matthew Bendet · 27 February 2014 - 21:54
United States · Florida International University

I have been trying to log in using my facebook username and password for the past 3 hours, and not once could I log in successfully.

Nikos Yanikos · 10 February 2014 - 18:07
Greece · FORTHnet SA

guys i cant even open the main forge of empires page. my friend open the page normally on his pc but i cant in mine !!! i did all possible solution and still nothing plz help !!! i was playing normally about an hour ago!!

Todd Randich · 9 February 2014 - 18:49
United States · Isomedia

Can't stay login and can not use chat window! This just started happing today.

Chris Blair · 26 January 2014 - 06:20
United States · Jackson Energy Authority

The initial page loads, but it doesn't recognize my login.

Tristan Talvi · 7 January 2014 - 21:32
United States · MTA Solutions

not even letting me on the world I play says I play in 2 separate worlds that I don't play in and wont recognize my true account SQUIRE

Eternal Mercy · 6 January 2014 - 09:54
United States · Cox Communications

Intermittent timeouts with FoE. Other websites are working fine; which indicates it is something to do with FoE's regional servers.

View Older Comments

Remaining 28 more comments.

Submit a comment using your Facebook ID.

Is Forgeofempires.com down for you right now? Submit your comments about Forgeofempires.com service status or report an issue below to let others know that they aren't the only ones having trouble. Please note that your country, service provider and browser information will be displayed next to your comment to better analyze a possible outage.