Warriorforum.com website not working? Is it down right now?

Warriorforum.com Server Status Check
warriorforum.com screenshot
WarriorforumWebsite Name:
www.warriorforum.comURL Checked:
Response Time:
Last Down:
Checking Warriorforum
Please wait while we check the server...
Warriorforum Website Status History
Warriorforum.com server report and response time

The above graph displays service status activity for Warriorforum.com over the last 10 automatic checks. The blue bar displays the response time, which is better when smaller. If no bar is displayed for a specific time it means that the service was down and the site was offline.

Service Status History

DateTimePing Time DateTimePing Time
30.Oct.2014
09:3570.07 ms. 
30.Oct.2014
12:3670.02 ms.
30.Oct.2014
15:4469.42 ms. 
30.Oct.2014
18:5469.62 ms.
30.Oct.2014
22:0470.6 ms. 
31.Oct.2014
01:1469.92 ms.
31.Oct.2014
04:1469.06 ms. 
31.Oct.2014
07:1469.31 ms.
31.Oct.2014
10:2469.72 ms. 
31.Oct.2014
12:5669.06 ms. 

* Times displayed are PT, Pacific Time (UTC/GMT -7)  |  Current server time is 15:06

We have tried pinging Warriorforum website using our server and the website returned the above results. If warriorforum.com is down for us too there is nothing you can do except waiting. Probably the server is overloaded, down or unreachable because of a network problem, outage or a website maintenance is in progress...

Can't Access Warriorforum - Troubleshooting Instructions

If the site is UP but you cant access the page, try one of the below solutions:

Browser Related Problems

Force a full refresh for the site. This can be achieved by pressing CTRL + F5 keys at the same time on your favourite browser (Firefox, Chrome, Explorer, etc.)

Clear the temporary cache and cookies on your browser to make sure that you have the most recent version of the web page. For instructions choose your browser :

Fix DNS Problems

A Domain Name System (DNS) allows a site IP address (192.168.x.x) to be identified with words (*.com) in order to be remembered more easily, like a phonebook for websites. This service is usually provided by your ISP.

Clear your local DNS cache to make sure that you grab the most recent cache that your ISP has. For Windows - (Start > Command Prompt > type "ipconfig /flushdns" and hit enter). For details choose your operating system :

If you can access a website at office or from a 3G network yet it's not working on your computer, it is a good idea to use an alternative DNS service other than your ISPs. OpenDNS or Google Public DNS are both excellent and free public DNS services.

Check our help page for step-by-step instructions on how to change your DNS.

Having Problems with Accessing Warriorforum.com?
▼ LAST 6 MONTHS ...
Steve Hards · 6 June 2014 - 04:24
United Kingdom · Tiscali UK Limited · Firefox 29.0 on Windows

Stuck on login 'accept new T&Cs' page, which is constantly refreshing itself and not moving on to next stage after button is clicked.

▼ MORE THAN 6 MONTHS AGO ...
Patrick Johnson · 11 April 2014 - 10:22
United States · Time Warner Cable

I'm getting the 403 Forbidden error. Strange! Can't access the site at all.

Baz Kar · 9 April 2014 - 18:32
Australia · Internode

Yep, it's down for me too. I can reach threads by their link but can't get to any roots of any categories or the root of the site or the root of my control panel. If I try to go to the root address I get a "file not found" text on a white page and it points to the cgi folder.

Bart Hennin · 9 April 2014 - 16:50
United States · Time Warner Cable

war room/JV room etc. keeps timing out before it can load

Angela Gatlin Edwards · 29 March 2014 - 17:36
United States · Comcast Cable

Yeah, it's definitely down. I have not been able to get in all day. Now it says "Page Not Found". Maybe they're changing servers or something.

Glen Hooke · 29 March 2014 - 14:57
Australia · iiNet Limited

What is going on with the Warrior Forum??

Suddenly from yesterday my access to the site is being block. Why?

I cannot access the WF using my usual login credentials. I get 'page ot found' message

I can get onto the WF using and all the sub-forums only as a 'guest' but using : http://anonymouse.org/ - however when I then try to login with my credentials I get a.... '403 Forbidden - access to this resource on the server is denied'

Is there server issues or what?

Michael Russell · 29 March 2014 - 09:44
New Zealand · TelstraClear

The latest when I try to get on the WF is a blank white page with the words "Site not found" a lot different than being parked

David Harkin · 29 March 2014 - 08:29
United Kingdom · Tiscali UK Limited

It would be nice to get a heads up if they are doing maintenance. Then again, it could be an unforeseen problem. Still down for me.

Just checked.. the main forum is down for me, but subforums are up. Strange.

Leana Ch'ng Pinto · 29 March 2014 - 04:02
Malaysia · TM Net

Relax, this exact things happened before 2 weeks ago. They'll be up within the day.

Income Journal · 29 March 2014 - 03:51
United Kingdom · Virgin Media

Wf seems to have been down a few times the past month or so. More than usual anyway.

Gian Sim · 29 March 2014 - 03:45
Philippines · Philippine Long Distance Telephone

still down... any news why it's down for so long?

Andreas Malm · 29 March 2014 - 03:32
Sweden · TeliaSonera AB

The Warrior Forum is so dead and “old news” that you have to find other scams on the internet to report about… LMAO!

Sh Toh · 29 March 2014 - 03:00
Singapore · SingNet Pte

Maybe they are changing web host? - The IM Forum

Luke Dennison · 29 March 2014 - 00:49
United Kingdom · T-Mobile (UK) Limited

Something is going on that i have not seen before

Michael Russell · 28 March 2014 - 22:51
New Zealand · TelstraClear

The forum is down and apparently the page I am getting is that the site has expired and is Parked.. a bit concerning I would say

Sudipa Sarkar · 28 March 2014 - 21:32
India · Wish Net Private Limited

It still says connecting.... but only white page so far! :-(

Shelby France · 20 March 2014 - 10:50
United States · Comcast Cable

still cant access warrior forum. Tried to reset password like it advices but still no email from them been over an hour.

Roman Usenko · 19 March 2014 - 23:08
Russia · Information Network

not working for me now((((

Hilaludin Wahid · 19 March 2014 - 21:44
Indonesia · netZAP Wireless Broadband Provider

warrior forum is down now

Neil Fontaine · 18 March 2014 - 02:37
United States · Comcast Cable

Warrior forums is timing out for me right now, but this site says it is working.

Vladimir Pereira · 25 February 2014 - 12:36
Canada · Telus Communications

I am also having a Data Base problem with the forum... Whats up?

Josan Iracheta · 20 February 2014 - 14:09
United States · AT&T U-verse

I'm getting the database error. What's up with warrior forum?

Linda Wright · 5 February 2014 - 05:01
United States · Hughes Network Systems

It's February 5, 2014 @ 7:59 EST and I get the database error. This is the first time ever that I have not been able to connect to the forum. I wonder if it may be a spyware issue on my computer.

Michael Kelley · 27 December 2013 - 07:33
United States · Colorado Internet Cooperative Association

Yes it is having severe database issues - it has been an ongoing problem now for quite some time. I hope they can get it fixed.

Jeremy Collins · 27 December 2013 - 07:15
United States · Comcast Cable

Seems like the Warrior forum is down at least once every day or two now.

Avneet Singh · 18 December 2013 - 22:30
India · Airtel Broadband

Warrior forum seems to having problem. It is not appearing properly. It is only showing 2 users online whereas at anytime it has 20k users online.

Guy Smith · 13 December 2013 - 07:12
United States · Cox Communications

Warrior Forum down for me too... Maybe it's a Friday the 13th thing...

Mark Sherris · 13 December 2013 - 04:19
United Kingdom · Virgin Media

well this is annoying especially when you have services up on the forum. Hopefully be back up soon!

Blogging Slogan · 13 December 2013 - 02:23
India · Airtel Broadband

Not loading for me as well, said on 13th Dec 2013

Michael Kelley · 13 December 2013 - 01:22
United States · Colorado Internet Cooperative Association

It appears to be down for everybody now

Michael Russell · 12 December 2013 - 23:11
New Zealand · TelstraClear

The Warrior forum has only been down for an hour at the least, have had no problems accessing the forum since about an hour ago.. not sure what the problem is maybe their doing maintenance or their just a server issue

Nina Svac · 25 October 2013 - 05:29
Canada · Telus Communications

yes, since yesterday

Stephen John Parkin · 17 July 2013 - 14:58
Canada · EastLink

I am having exactly the same problem as everyone else. The Warrior Forum is down or being blocked.

Julian Kane · 11 April 2013 - 13:42
Canada · Cogeco Cable

It's unbelievable, the Warrior Forum has been down since 11:00am yesterday...

You figure with the money that they rake in, that they would have a better Tech Team to deal with their issues...

Mohan Saravanan · 15 October 2012 - 01:54
India · Airtel Broadband

Hi, i am trying to access. But not connecting the warrior forum.

Joe Scoulou · 14 October 2012 - 11:29
Australia · Optus

It's been 5 days now & I still cant get in

Stephen Hall · 12 October 2012 - 05:15
United States · Comcast Cable

I have not been able to access the Warior Forum for 3 days now... Is anyone else having this problem?

Derek Pankaew · 27 September 2012 - 17:22
United States · Comcast Cable

Kenneth, I'm having the same issue. It works through online proxies, but not from my direct IP ...

Kenneth Dockins · 26 September 2012 - 12:42
United States · Time Warner Cable

Okay, regardless of whatever is being said, WarriorForum.com will still not load onto my browser. This is the case for both Internet Explorer and Firefox. The exact error is:

"Problem Loading Page" "The connection has timed out." "The server at www.warriorforum.com is taking too long to respond."

Does anyone know how to fix this situation?

Shaked Tayeb · 12 September 2012 - 04:24
Israel · Hot-Net internet services.

can acess this for a week is my ip blocked or somthing?

Ricky Williams · 11 September 2012 - 08:19
Canada · Rogers Cable

Though it was just me or my cpu ...

Sam Baz · 9 September 2012 - 05:48
United Kingdom · Virgin Media

Hi, I have been trying to access the site for 2 days, I can't seem to get on the site!

Simo Gold · 9 September 2012 - 01:56
Czechia · Telefonica Czech Republic

I am trying to access the forum since yesterday but the response time is taking long time. Any advice please

Submit a comment using your Facebook ID.

Is Warriorforum.com down for you right now? Submit your comments about Warriorforum.com service status or report an issue below to let others know that they aren't the only ones having trouble. Please note that your country, service provider and browser information will be displayed next to your comment to better analyze a possible outage.