Myfamily.com website not working? Is it down right now?

Myfamily.com Server Status Check
myfamily.com screenshot
MyfamilyWebsite Name:
www.myfamily.comURL Checked:
Response Time:
Last Down:
Checking Myfamily
Please wait while we check the server...
Myfamily Website Status History
Myfamily.com server report and response time

The above graph displays service status activity for Myfamily.com over the last 10 automatic checks. The blue bar displays the response time, which is better when smaller. If no bar is displayed for a specific time it means that the service was down and the site was offline.

Service Status History

DateTimePing Time DateTimePing Time
22.Apr.2014
04:5446.78 ms. 
22.Apr.2014
07:0446.89 ms.
22.Apr.2014
10:2446.83 ms. 
22.Apr.2014
13:3346.57 ms.
22.Apr.2014
16:1647.02 ms. 
22.Apr.2014
18:2547.09 ms.
22.Apr.2014
20:3447.06 ms. 
22.Apr.2014
22:4447.04 ms.
23.Apr.2014
01:3646.93 ms. 
23.Apr.2014
03:4347.12 ms. 

* Times displayed are PT, Pacific Time (UTC/GMT -7)  |  Current server time is 04:48

We have tried pinging Myfamily website using our server and the website returned the above results. If myfamily.com is down for us too there is nothing you can do except waiting. Probably the server is overloaded, down or unreachable because of a network problem, outage or a website maintenance is in progress...

Can't Access Myfamily - Troubleshooting Instructions

If the site is UP but you cant access the page, try one of the below solutions:

Browser Related Problems

Force a full refresh for the site. This can be achieved by pressing CTRL + F5 keys at the same time on your favourite browser (Firefox, Chrome, Explorer, etc.)

Clear the temporary cache and cookies on your browser to make sure that you have the most recent version of the web page. For instructions choose your browser :

Fix DNS Problems

A Domain Name System (DNS) allows a site IP address (192.168.x.x) to be identified with words (*.com) in order to be remembered more easily, like a phonebook for websites. This service is usually provided by your ISP.

Clear your local DNS cache to make sure that you grab the most recent cache that your ISP has. For Windows - (Start > Command Prompt > type "ipconfig /flushdns" and hit enter). For details choose your operating system :

If you can access a website at office or from a 3G network yet it's not working on your computer, it is a good idea to use an alternative DNS service other than your ISPs. OpenDNS or Google Public DNS are both excellent and free public DNS services.

Check our help page for step-by-step instructions on how to change your DNS.

Ads by Google

Having Problems with Accessing Myfamily.com?
Jayne Mundell · 30 March 2014 - 13:55

MyFamily site has been down since this morning. Can't get to any of them. =\

Buddy Lollar · 30 March 2014 - 13:20

I wish that the site still sent out notices when a new picture is posted on the site. Members would visit the site more often and that makes it better.

Pat Malinowski · 30 March 2014 - 13:13

I was working on MyFamily.com and it completely quit working. When I went to retrieve it, it would not retrieve. Cannot find MyFamily.com anywhere.

Melva Hamilton Hofmann · 21 February 2014 - 06:46

I cannot access my family groups. No response when I contacted help. grrrr!

Shirley Ring Weick · 4 February 2014 - 12:40

Cover Photo is not showing and Can not upload photos...

Brenda Snider · 26 January 2014 - 17:30

I have had my site since 1998, when they were free and started subscribing to the paid version when that was required. About once a month, I encounter this "site can't not be found" error message. The site has about 400 members and over 3000 pages of content. I don't know why this continues to happen, you'd think by now they'd know what is happening and would be able to fix the problem a lot faster.

Mary Havens · 21 January 2014 - 05:47

The requested URL /buildy.html was not found on this server

Sherry Chilton · 21 January 2014 - 04:36

1.0 Site is not up and running. Server error message since 5 AM central. Yesterday it was the disappearing image issue that took all day to deal with. Today begins waiting for the team to arrive and work through server issues. All the while, it is true the 2.0 site is functional... ::sigh:::

Peru August 2012 · 21 January 2014 - 04:30

Test of login page contraindicates existence of problem replicated by many version 1.0 site members this morning. myfamily.com/isapi.dll?c=site&htx=main points to http://blog.myfamily.com/buildy.html, which results in a "Not Found" error message for Apace/2.2.22 Server at blog.myfamily.com Port 80. Have cleared cache and attempted access using three browsers: Firefox, Mozilla and Google Chrome. 6:30 A.M.

Carole Roper · 16 January 2014 - 14:19

My site visitors are having problems for the last few days. They cannot view the photos if they are signed in. The site is set as "Public" but the ones who are signed only see a placeholder with the MyFamily logo. Could someone please help, it is a real problem.

Richard S Rohde · 16 January 2014 - 05:19

I have the 3.0 version of MyFamily.com and its having all the same problems, I first noticed problems back in September, thought it was my computer, but it's not. I have four sites I pay for, one has 32 members. After not having pictures available, I was able to see them and post more, but today the sites are DOWN again...

Sandy Gold · 12 January 2014 - 21:32

Still have all the pages with the text (profile pages, 2 family pages), but no photos--just the myfamily.com logos in their places.

Vanessa Scholl-Courtney · 8 January 2014 - 10:57

i was able to see and post photos yesterday jan 7--now there are no photos available again... today jan 8

Gregor Laing · 8 January 2014 - 05:36

All the photos are back and I sucessfully posted more last night although no email notifications are being sent

Gregor Laing · 5 January 2014 - 15:32

All the photos disappeared last week. When the site is opened the outlines of the pics are there but gradually disappear leaving a blank page. this has been reported and been acknowledged although no action taken to date

Vanessa Scholl-Courtney · 5 January 2014 - 11:52

I have not been able to view or post for several days...

Teresa Del Pozo · 3 January 2014 - 08:28

I spoke yesterday to Peggy witch I dont know who is she and didnt know whats going on she was going to report to technician until today nothing happens I'll ask her how long is going to take to fix the problem answer I don't know great service having incompetent people

Dave Inchausti · 21 December 2013 - 08:59

I believe classic.myfamily.com (1.0) is down at this time. Have had other members from other locations not able to reach it . I was on earlier this morning.

Herman De Vries · 7 October 2013 - 18:32

Where to begin. First of all, support is no help whatsoever.

Problem - our domain has disappeared and with more than 5, 000 worldwide members on our site no one can access. And trying to use the old way, using version 1, we just get a blank page.

We paid for our domain, and myfamily is supposed to keep it current. Well, it expired, and we have a site with 500 private photo albums, almost 100, 000 photos and we are getting no help, although it is myfamily's fault.

The site is the World of Woodturners, the largest site you have, and you have gotten hundreds of new users from among our people. We have had a site since 2001 and this is even more frustrating than the dozens of times the site goes down.

Any comments - my family?

Dave Inchausti · 23 September 2013 - 20:01

Sherry... we are up and running for now. Cross your fingers. As a side note, the mountain in the background of your photo looks amazingly like Carbonate Mt. If not it is a haunting likeness. I spent hundreds of hours climbing it in the days of my youth.

Sherry Chilton · 23 September 2013 - 11:28

Back up and running. If your people still have problems, they will need to clear their browser cache. If they STILL have problems, they can call 1-888-265-7491. About a 15 minute wait on Monday at 1PM

Sherry Chilton · 23 September 2013 - 10:07

At 1 PM Eastern time, 2 hours after the myfamily.com technical support team returned to work from the weekend, there is finally a message on the customer support number which acknowledges that they are having problem with their site and are working to address the issue as quickly as possible. If you want to speak to a representative, there is a very long wait to do so. After a substantial hold time, I hung up - not knowing whether they had 1, 2 or 3 people in the back office -- concluding it was more important for them to be able to repair the problem than to listen to me vent. If any of you DO speak with LHB, please update the rest of us, thanks. And no, our site has not regained it's functionality.

Katie Stone · 23 September 2013 - 05:24

We use MyFamily 1.0 and again are having the issue of not being able to post. Extremely frustrating. Customer service stands by their claim 'it must be MY server' causing problems. Even though everyone in my family is using different servers. Anyone on here found a similiar site that doesn't have all the issues?

Dave Inchausti · 22 September 2013 - 22:12

I think you are correct in your assessment, Sherry, and it would be interesting to know how many 1.0 sites still exist. I remember that a significant number of us refused to migrate but I'm betting that the attrition caused by Facebook and the other social website alternatives has significantly reduced our numbers . I wish I knew the strategic intentions of the powers to be relative to how they intend to attrit us and how accomodating they will be to allow us recapture our monstrous data bases as part of a strategy to drive us away. My largest site has 6 gigs and 12 years of accumulated data residing on their servers and thousands of pages of news commentary. Frightening prospects...

Sherry Chilton · 22 September 2013 - 15:54

Dave, as best I can tell it is only effecting the 1.0 site. I had migrated over content to the new site way back and intended to go with it, until I realized that anyone on the newer site could migrate everything from the site to ancestry.com with the click of a button and what was once private, would be immediately public. I contacted customer support about that particular feature, basically requesting the equivalent of a kill switch that would prevent it, as some of the family discussions on the private site have absolutely no business being placed in public, searchable databases. It was taken under advisement and rejected, so we stayed with 1.0. However, I just tested the old "new site", and it is operating like a charm. I can post anything, change cover pages, etc. So, I would think they are doing all they can not do to retain the 1.0 sites. We very simply do not fit into the business model because we are taking up server storage space and they can't charge others to access the data. IMHO. We'll find out hopefully tomorrow. Also, it would be interesting to learn how many of "us" there are. Imagine we are a small, dying breed, which makes the need to identify an alternative way service provider an imperative.

Mary Van Tol · 22 September 2013 - 15:31

Unable to post or renew a site since Thursday, September 19th.

Betty Swanson · 22 September 2013 - 12:38

Can someone recommend a good site for me to transfer my data to since they sure don't seem to be doing their job. They promised me a rebate months ago and I've not seen a dime of it which didn't surprise me. I never expected it anyway. If I could find a good place to transfer my data to, I would leave.

Paul Cousineau · 22 September 2013 - 09:40

yes nothing seems to be working on this site at present. none of my family members are able to post

Dave Inchausti · 22 September 2013 - 06:53

I contacted the Ancestry customer support people and got only a myfamily tel # which informs callers that normal hours are bla bla bla ... I told the Ancestry person that I was stunned that the myfamily people would leave us all for a weekend with this major system problem and no communications vehicle to get updates and an indication that someone there really cared and were working on a fix. I almost feel that neither the sub nor the parent seem to care about customer service anymore and wish we would go away. Does anyone who is commenting on this thread represent the later versions of myfamily or are we all 1.0 users?

Russ Garner · 22 September 2013 - 05:14

Yes, our myfamily group started having problems posting to all three of our Searey friends and owners sites on the 19th. of September also.

Lee Bennett · 21 September 2013 - 22:19

We renewed our 4 MyFamily 1.0 sites this month, and this is the thanks we get! Now we haven't been able to post anything for over three days, and no acknowledgement of a problem. What is happening?

Nancy Caspers · 21 September 2013 - 19:14

Sites been down for almost 43 hours... getting ridiculous... could they at least tell us whats going on? Also ready to take my money somewhere else!

Patricia Leonard · 21 September 2013 - 11:38

mine hasn't worked since yesterday morning early

Sherry Chilton · 21 September 2013 - 11:27

As they are an ancestry subsidiary, has anyone contacted ancestry.com's - 1-800-262-3787 Customer Solutions Associates? They are available 7 days a week, 9 am to 11 pm ET. The difference in customer service and tech support is pretty telling in itself in terms of differential investments, and where they intend to migrate everything -- to fullbore public social media, online trees and DNA database development. Does anyone else offer a platform for these private sites like 1.0?

Sherry Chilton · 21 September 2013 - 11:16

As many of you have probably done as well, I called technical support this morning. There is no outage recording, only the recording to call back during normal business hours, which is 11 AM Monday EASTERN time. I have emailed my people letting them know of the outage and wishing them all a good weekend. I also have emailed technical support suggesting that when they are having issues like this, it would be appreciated if they emailed the administrators. Way back, they used to do this so that we were aware of issues and able to inform our own people. Did ANYONE call them yesterday during business hours? I emailed them yesterday, but have not received even a confirmation of receipt of that communication. One question I do have... is this problem limited to the 1.0 platform or is it effecting the newer platform as well? Thanks, and sorry for all your frustrations too.

Dave Inchausti · 21 September 2013 - 07:13

This is indeed a frightening trend and the responses that no backup is available for our data is a daunting thought. I can't believe that they would be allowed to treat this large customer base in this manner. There must be some consumer protection available to us

Dolores Edwina Lockert Ard · 21 September 2013 - 07:13

Folks, this is Ancestry.com - the same organization that took our posted family trees and is now getting paid for the information that we took so long and so much effort to accumulate. What do we expect even tho we are paying them to maintain our sites. Have you checked the source pages? No improvements. Well, maybe the Colorado floods inundated their servers.

Cathy Billotte Yorio · 21 September 2013 - 07:08

I'm having the same problems as others. I can't post pictures or replies... only read what's alread there. This has gone on for over 24 hours and nothing seems to be happening to fix the problem. I will cancel if this goes on for much longer.

Sherry Chilton · 21 September 2013 - 04:37

Problem with myfamily.com since midnight September 19, 2013. Server is accessible but no ability to input comments, change cover photo, front page, upload photos etc. A full 30 hours has lapsed with viewing and navigation operability only. It is operating as a database only. I agree with previous commenters regarding service deterioration. We have already lost photos and been told they are not replaceable. Tough to copy 12GB ourselves and we feel very much at risk when we can't even change a front page photo in 30 hours!

Lee Bennett · 20 September 2013 - 20:59

I've been trying to post items to 4 MyFamily.com sites I administer, and nothing will post. I can view the pages, refresh the page and navigate the site, but nothing will post. It's now midnight, EDT on September 20, 2013. Whats happening?

Jayne Mundell · 20 September 2013 - 20:41

We cannot post or reply on our www.myfamily.com site. It is currently readable/viewable only.

Judy Spradlin · 20 September 2013 - 15:29

I can log on to the site but cannot post anything today. I think we are going to cancel our site as soon as I move everything. This is ridiculous. They are being paid to maintain the sites. I believe we should get a refund for the times the site is down.

Sandbulte Lloyd · 7 July 2013 - 18:55

Members of our group are no longer receiving email notifications of myfamily.com posts. Why is that?

Annette Bowles · 14 June 2013 - 09:31

Site has been down since yesterday. We can see our posts but can't respond. I hope someone gets this site back up and running soon. This seems to be an ongoing problem.

Katie Stone · 14 June 2013 - 06:51

We have been unable to post or reply on Myfamily for two days.

Joan Potter Kramer · 14 June 2013 - 05:01

Our site is readable, but we can't post or delete anything. We have family events we are planning and need to post dates, places, times but can't since yesterday morning. So frustrated!!!

Mary Charles Severinghaus · 13 June 2013 - 18:37

This website has been getting worse and worse. We've had an account there for 12 years and are so worried we're going to lose all the info there. My sister contacted them about a backup and they said they do not provide such a service, so whenever you can get back on, copy everything you value!!!

Betty Dotson Renick · 15 April 2013 - 03:21

Continuous problems for the 14 years I've had a site. Problems have worsened over the years and calls and Emails produce no results.

Joy Austin Wilson · 13 February 2013 - 16:54

Please fix the Sites. We pay for them and should expect better service. My site has been down for three days. Many missing photos. At least you should notify us to let us know what is going on.

Erik Lindholm · 10 December 2012 - 10:07

Unable to add new members since yesterday!

Zulraini Shaari · 10 December 2012 - 04:46

I am having problems posting anything on Myfamily.com since yesterday. Does anybody else having the same problems?

Submit a comment using your Facebook ID.

Is Myfamily.com down for you right now? Submit your comments about Myfamily.com service status or report an issue below to let others know that they aren't the only ones having trouble.

Rate Myfamily

Myfamily.com has been rated 1.6 out of 5 points. A total of 15 votes cast and 51 users reviewed the website.

Website Status Checker Bookmarklet

Once added to your toolbar, this button will let you to check the status of a site from your browser's toolbar.

Just drag the text your bookmarks bar : Down Right Now?

Similar Websites
myheritage.com - MyHeritage
Server is up. Last checked 13 hours 52 mins ago.
mocospace.com - MocoSpace
Server is up. Last checked 4 mins ago.
migente.com - MiGente
Server is up. Last checked 6 hours 46 mins ago.
glogster.com - Glogster
Server is up. Last checked 2 hours 51 mins ago.
blinklist.com - BlinkList
Server is up. Last checked 16 hours 25 mins ago.
plus.google.com - Google+
Server is up. Last checked 5 mins ago.
vampirefreaks.com - Vampire Freaks
Server is up. Last checked 1 hour 43 mins ago.
piczo.com - Piczo
Server is up. Last checked 4 days 9 hours 32 mins ago.
arto.com - Arto
Server is up. Last checked 8 days 19 hours 54 mins ago.
Down Right Now
lotro.com - The Lord of the Rings Online
Server is down. Last checked 3 secs ago.
ddo.com - Dungeons & Dragons Online
Server is down. Last checked 27 secs ago.
irctc.co.in - IRCTC Reservation System
Server is down. Last checked 40 secs ago.
justgiving.com - JustGiving
Server is down. Last checked 49 secs ago.
ee.co.uk - EE UK
Server is down. Last checked 59 secs ago.
Latest Sites Checked
battle.net - Battle Net US
Server is up. Last checked 1 sec ago.
bing.com - Bing
Server is up. Last checked 1 sec ago.
cableone.net - Cable One
Server is up. Last checked 3 secs ago.
lotro.com - The Lord of the Rings Online
Server is down. Last checked 3 secs ago.
opencart.com - OpenCart
Server is up. Last checked 3 secs ago.